Welcome to Mobilism...


the single largest user-powered database of apps, games and books for mobile device users of all platforms! With over a million members and millions of users, over 600 000 releases and countless posts, Mobilism is one of the largest and oldest mobile content sites, as well as, in our opinion, by far the most organized one.

Sit back, download some books, learn something new, and enjoy your stay! When you're ready, you can head to the forums by Clicking Here.


Posted by: Henry2 at Yesterday, 7:53 am in Office/Productivity

GoodNotes 4 - Notes & PDF v4.11.3
Requirements: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.
Overview: GoodNotes lets you take beautiful handwritten notes and annotate PDF documents.

Image Image
...
View full post
Replies: | Post reply
Posted by: Henry2 at Yesterday, 6:59 am in Phone Utilities

Workman's Construction Calculator v1.2.2
Requirements: Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.
Overview: The calculator has been rebuilt and it's built for the trades, now.

Image Image
...
View full post
Replies: | Post reply
Posted by: Henry2 at Feb 20th, 2017, 3:32 pm in Phone Utilities

Phone Doctor Plus v4.0.6
Requirements: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.
Overview: It doesn’t matter how much free space you have or how healthy your battery is. Using an app like Phone Doctor Plus will help you pinpoint problems quickly and easily

Image Image
...
View full post
Replies: | Post reply
Posted by: Henry2 at Feb 20th, 2017, 3:01 pm in Phone Utilities

Nomorobo – Robocall Blocking v1.0.5
Requirements: Requires iOS 10.0 or later. Compatible with iPhone.
Overview: Stop annoying robocalls and block calls from telemarketers!

Image Image
...
View full post
Replies: | Post reply
Posted by: Henry2 at Feb 20th, 2017, 11:02 am in Office/Productivity

Contacts Pro - Contacts Backup v2.0.1
Requirements: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.
Overview: This tool will maintain and manage iPhone contacts by cleaning duplicated entries and backup by upload to box, dropbox, google drive or gmail and other sharing ways.

Image Image
...
View full post
Replies: | Post reply
Posted by: Henry2 at Feb 19th, 2017, 7:09 pm in Office/Productivity

iPassworder v5.1.1
Requirements: Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.
Overview: iPassworder is a fast, convenient and very easy to use password manager.

Image Image
...
View full post
Replies: | Post reply
Posted by: Henry2 at Feb 19th, 2017, 3:32 pm in Internet/Network Utilities

Prompt 2 v2.5.8
Requirements: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.
Overview: THE EASY, POWERFUL, AND BEAUTIFUL SSH CLIENT.A brand-new app, with great new features, Prompt 2 gets the job done.

Image Image
...
View full post
Replies: | Post reply
Posted by: Henry2 at Feb 19th, 2017, 1:12 pm in Education

iSchool - School diary v3.0.8
Requirements: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.
Overview: This is an English version of a famous Russian study organizer (for schools and universities).

Image Image
...
View full post
Replies: | Post reply