Section head: merry60
Jan 9th, 2018, 8:01 pm
Disk4mat wrote:
superman5150 wrote:Why is it still IMPOSSIBLE to download the app update from the actual app?!?!

As has been written multiple times here, and is written in CAPS in the update message you see when you're asked to update in the app, you have to uninstall the previous version before installing this one.


It's amazing how many people'll skip right over that, even though notice of the newest update's right there where they'd read! Though I will admit it's a bit cumbersome for those of us who've been rather absent for much long the time to scour the thread for said thread:

Disk4mat wrote:v2.0.0.6 released. This is a big update and will require a clean install, please uninstall the previous version.

- added: My Applications (what you guys requested from Mobilism v1, used to check for updates for existing apps)
- added: dark theme (as requested, for those who dont like the bright backgrounds)
- added: automatic backup and restore of watchlist (so that you dont lose your watchlist if you uninstall)
- added: updates - ignore beta versions in releases (option used to not see betas when the update feature is looking for latest versions in Mobilism's database)
- fixed: some UI color settings
- fixed: initiate correct download directory
- fixed: notifications for Android Oreo (caused downloads and other notifications to not show up)
- fixed: deletion of downloaded releases on mob2x uninstall

- note > directory WatchlistBackup will be used to update,
restore and backup your custom watchlist.
Feel free to copy it to a safe place at app closure
but do not remove it.

Enjoy!


https://forum.mobilism.org/viewtopic.php?f=63&t=214777&start=3035 - that way, it's anchored to the 1st post on that page.


And thanks - I've hardbricked my phone while overclocking its battery (heh). Once I get a new phone (I don't trust/like the newer Samsungs & locality restrictions exist on which otherworldly models one can contract/buy, so I hope it backports in compatibility: Call me the cynic. I prefer to manually edit permissions in reverse-engineer ways of sorts than they add all the crap in & I've gotta scrap more of the phone to get it barebones useful: referring to Google & Carrier, FWIW), I'll try this out. Until then, it's downloaded locally on my desktop. Last time I'd used it was 1.9.1 or 1.9.2 and the premium/platinum login kept logging-out after some certain X interval of time once we'd terminated the app. Did that get fixed please?
Jan 9th, 2018, 8:01 pm
Jan 9th, 2018, 9:04 pm
@ima11 yes, the logging out of Premium issue never existed in v2. This new version was written from scratch.
Jan 9th, 2018, 9:04 pm
Jan 11th, 2018, 5:51 am
My 2.0.0.6 keeps crashing when I try to open 'My Applications'. All it shows in the toast is "error" and tries to mail an error log.
Jan 11th, 2018, 5:51 am
Jan 11th, 2018, 5:51 am
GyroDawn wrote:My 2.0.0.6 keeps crashing when I try to open 'My Applications'. All it shows in the toast is "error" and tries to mail an error log.

Have you mailed the error log? That way our devs can take a look at what is causing it.
Jan 11th, 2018, 5:51 am
Jan 11th, 2018, 7:33 pm
Disk4mat wrote:
GyroDawn wrote:My 2.0.0.6 keeps crashing when I try to open 'My Applications'. All it shows in the toast is "error" and tries to mail an error log.

Have you mailed the error log? That way our devs can take a look at what is causing it.


Yes, I've sent the error logs multiple times. Just wanted to post here as an FYI.

Thanks for the reply.
Jan 11th, 2018, 7:33 pm
Jan 12th, 2018, 2:33 am
I've used v1 for years. v2 is amazing. Thanks for all the work you all do here!
Jan 12th, 2018, 2:33 am
Jan 13th, 2018, 3:13 am
For the 'my apps' crash, mine did the same but I found that if there is something in the 'downloaded' section of 'my apps' it doesn't crash.
Jan 13th, 2018, 3:13 am
Jan 15th, 2018, 6:51 am
Mine is crashing also everytime I try to open my applications have sent the error log numerous time, haven't heard anything back....


GyroDawn wrote:
Disk4mat wrote:
GyroDawn wrote:My 2.0.0.6 keeps crashing when I try to open 'My Applications'. All it shows in the toast is "error" and tries to mail an error log.

Have you mailed the error log? That way our devs can take a look at what is causing it.


Yes, I've sent the error logs multiple times. Just wanted to post here as an FYI.

Thanks for the reply.
Jan 15th, 2018, 6:51 am