Feedback or requests for help with the site.
Mar 3rd, 2019, 3:03 am
I can log in
But then the site doesn't recognize me and won't allow me to seach for a book.
Mar 3rd, 2019, 3:03 am
Mar 7th, 2019, 6:45 am
For some reason I am unable to log into my Premium account when I try to direct download through clicking the blue arrow.
When I am on the MBL Services page I can log in perfectly fine. This is after I just changed my password. Do I need to wait for a bit before I can begin downloading? Thanks!
Mar 7th, 2019, 6:45 am
Mar 7th, 2019, 6:24 pm
darkone108 wrote:For some reason I am unable to log into my Premium account when I try to direct download through clicking the blue arrow.
When I am on the MBL Services page I can log in perfectly fine. This is after I just changed my password. Do I need to wait for a bit before I can begin downloading? Thanks!

Do you have any special characters in your Premium password? Try changing the password to something alphanumeric-only. We've seen some special characters causing problems before.
Mar 7th, 2019, 6:24 pm
Apr 4th, 2019, 12:07 pm
How to unsubscribe from all e-mails except unsubscribe from topic?
Apr 4th, 2019, 12:07 pm


Image
May 11th, 2019, 6:36 pm
Disk4mat wrote:
darkone108 wrote:For some reason I am unable to log into my Premium account when I try to direct download through clicking the blue arrow.
When I am on the MBL Services page I can log in perfectly fine. This is after I just changed my password. Do I need to wait for a bit before I can begin downloading? Thanks!

Do you have any special characters in your Premium password? Try changing the password to something alphanumeric-only. We've seen some special characters causing problems before.


I am also having this issue. My password is all lowercase and only alphanumeric. I downloaded fine but after changing the password I get an error saying incorrect user or pass. I have logged out of both MBL and my regular account and logged back into both with no help
May 11th, 2019, 6:36 pm
Jun 9th, 2019, 1:52 pm
I can't see any images posted at images.mobilism.

Hope it's a temp glitch. On a similar note, wonder why images.mobilism isn't in https.

Edit: they are back.
Jun 9th, 2019, 1:52 pm
Jun 15th, 2019, 12:58 am
Getting an error message "mblservices.org took too long to respond."
Jun 15th, 2019, 12:58 am