Support for everything about jailbreaking.
Sep 23rd, 2010, 4:07 am
Hi, I am new to this forum and not quite sure this is the right place to post this question but here it is:

I was looking to update my 3gs 3.1.3 to 4.1 and jailbreak with the new snowbreeze that came out today.

Though it doesnt work on 3gs with new bootrom so i looked to see how can i be sure about it.

Someone told me if model starts with MC its new bootrom and if serial 4th and 5th numbers are 40 or more its new.

Well my model starts with MC and my serial is ...17......

Is that a new bootrom? + if you have any advice like if i should go with 4.0.1 instead or anything, i would apreciate a lot.

Thanks in advance! :)
Sep 23rd, 2010, 4:07 am
Sep 23rd, 2010, 10:17 am
iOS4.1 is not jailbreakable yet on 3GS.
Mine is MC and the serial no is 38 and it has the old bootrom.
Sep 23rd, 2010, 10:17 am

ex
MOBILISM.ORG
Image
SUPPORT DEVELOPERS. IF YOU LIKE IT, BUY IT.
Sep 23rd, 2010, 11:25 am
thx for your answer!

but yeah since today there is a way to cook your own jailbroken ios 4.1 ispw

not sure if we can post outside links but here it is: http://www.redmondpie.com/jailbreak-iphone-3gs-new-bootrom-on-ios-4.1-with-sn0wbreeze-2.0-custom-firmware-guide/

Seriously i think ill stay with 3.1.3 for a while since everyone are saying that 4.0 and 4.0.1 totally screws 3gs and i don't know if 4.1 fixed those issues for 3gs

Let me know if theres anything i am missing.

Thanks again!
Sep 23rd, 2010, 11:25 am
Sep 23rd, 2010, 11:26 am
Thanks for the link.
I'm gonna try it out tonight and post here the results.
Sep 23rd, 2010, 11:26 am

ex
MOBILISM.ORG
Image
SUPPORT DEVELOPERS. IF YOU LIKE IT, BUY IT.
Sep 23rd, 2010, 11:32 am
awesome!!! I'll come and check here later today.

Hope everything goes smooth. oh and be aware that you won't be able to downgrade (from what i heard)

Thanks again, much apreciated! ^^
Sep 23rd, 2010, 11:32 am
Sep 23rd, 2010, 11:52 am
If i can upgrade to 4.1 it won't be a need for downgrade. But anyway, i can downgrade at any time. I have all shsh blobs saved.
Sep 23rd, 2010, 11:52 am

ex
MOBILISM.ORG
Image
SUPPORT DEVELOPERS. IF YOU LIKE IT, BUY IT.
Sep 23rd, 2010, 12:07 pm
just saying, because you know, some people might have told themselves the same thing with 4.0 and they ended up screwed.....i'm not sure if ios4.1 really fixed major bugs for 3gs so it's a bit risky but it might be worth it.

Have you been using 4.0 or 4.0.1? if yes, have you experienced any issues? if not, then i would understand.

I haven't myself (3.1.3 here) so reading about ios4 scares me.....a lot lol.
Sep 23rd, 2010, 12:07 pm
Sep 23rd, 2010, 2:06 pm
I've been using IOS4.0 since the first day the JB appeared. I didn't find any major issues. It seemed faster then my previous 3.1.2 but the safari browser crashes more often.
Overall i find 4.0 better than 3.1.2
For me, it's absolutely no risk but for most users it is a big risk, especially if they don't have shsh blobs saved...
Sep 23rd, 2010, 2:06 pm

ex
MOBILISM.ORG
Image
SUPPORT DEVELOPERS. IF YOU LIKE IT, BUY IT.
Sep 24th, 2010, 12:29 am
So it's worth the try (im using opera mini anways)....well i'll wait to see if that 4.1 worked fine for you and then i'll try with mine which is new bootrom and see what happens.

I've been reading a bit about 4.1 today and it seems that there shouldnt be any issue with 3gs, so that should fix what people have been experiencing with 4.0/4.0.1

Thanks for your info buddy!
(excuse my english, french here)
Sep 24th, 2010, 12:29 am
Sep 24th, 2010, 8:21 am
Well actually, my 3gs came with 3.1.3 so i dont have shsh for 3.1.2 and since i have new bootrom, i simply cannot move to 4.1 unless there is a way i havent heard of to downgrade 3.1.3 to 3.1.2 without shsh.

I might try 4.0.1 then if you say 4.0 is fine.

I hope 4.1 goes smooth for you, i'll have to wait until a 4.1 jb release, if so.
Sep 24th, 2010, 8:21 am
Sep 24th, 2010, 9:16 am
I have tried yesterday to Flash but i had a problem with the internet connectivity... Guess i'll have to postpone the flashing for this weekend...
When you installed cydia, did you click on make my life easier ? If you did, what do you have in the red thingy from this pic:
Image
Sep 24th, 2010, 9:16 am

ex
MOBILISM.ORG
Image
SUPPORT DEVELOPERS. IF YOU LIKE IT, BUY IT.
Sep 24th, 2010, 9:33 am
I have 3.1.3, 4.0, 4.0.1 because when i bought the phone this summer, it came with 3.1.3 so i don't have 3.1.2 shsh.

Well i am currently upgrading to ios 4.0.1 and should be done in a minute. I'll let you know if it's smooth on my 3gs new boot ^^

Thanks for your help! Really appreciate
Sep 24th, 2010, 9:33 am
Sep 24th, 2010, 10:00 am
Good luck. Waiting for your input.
Moved to jailbreaking.
Sep 24th, 2010, 10:00 am

ex
MOBILISM.ORG
Image
SUPPORT DEVELOPERS. IF YOU LIKE IT, BUY IT.
Sep 24th, 2010, 10:51 am
Well well... my signal went from 5 bars to 1, the overall speed seems to be a bit slower, keyboard is a bit slow too.

Ios 4 looks cool though and i like the folder thingy, can't wait till i can put a working ios 4.x on my 3gs, but right now, i might keep it a day or 2 to really test the hell out of it but yeah i think ill go back to 3.1.3 until i can try 4.1

Thanks a lot for all your help though, and i wish you the best with 4.1 :D
Sep 24th, 2010, 10:51 am
Sep 24th, 2010, 11:11 am
Well, even if you have 1 bar, it's just a cosmetic modification. The quality is the same, the bars are more accurate.
Sep 24th, 2010, 11:11 am

ex
MOBILISM.ORG
Image
SUPPORT DEVELOPERS. IF YOU LIKE IT, BUY IT.